Fogio elettronico o spread-sheet (Excel)

Il programma EXCEL (di Microsoft Office) è un foglio elettronico che permette di creare tabelle di calcolo.
E’ organizzato in cartelle di lavoro costituite da più fogli di lavoro.
I fogli di lavoro sono formati da celle disposte su colonne e righe (le colonne sono indicate con lettere e vanno da A a IV; le righe sono indicate con numeri e vanno da 1 a 65.536).

La finestra visualizzata di Excel comprende:
•barra del titolo
•barra menu a tendina (gli stessi menu di Word, tranne il menu Tabella che in Excel è sostituito col menu Dati)
•barra degli strumenti standard
•barra degli strumenti di formattazione
•riga di visualizzazione contiene il riferimento cella e la barra della formula in cui inserire formule ed effettuare correzioni

•area di lavoro
•barra di stato
•barre di scorrimento

F5 = tasto funzione che serve per ricercare una cella

F2 = tasto funzione che serve per apportare correzioni nella cella

I dati da inserire possono essere:
1. etichette o testi = cominciano con una lettera. Di default sono allineati a sx
2. valori =cominciano con un numero da 0 a 9 oppure con i simboli: + - % ( ) Di default sono allineati a dx
3. formule = cominciano con il simbolo uguale = senza spazi tra gli elementi. La formula è costituita da operandi (ad es. A1) e operatori aritmetici (+ - * / ^)
4. funzioni = sono stringhe di testo chiamate argomenti, separati dagli operatori di riferimento, racchiuse
dentro le parentesi tonde. Ci sono funzioni matematiche, statistiche, finanziarie, ecc.

Gli operatori di riferimento sono di due tipi:
•intervallo (simbolo dei “due punti” :) = indica “da ... a”, cioè tutto l’intervallo della zona delimitata da una cella iniziale e da una finale. Ad es. la somma A1:A5 cosidera tutte le celle anche A2 A3 e A4;
•unione (simbolo del “punto e virgola” ;) = indica l’unione delle sole celle indicate. Ad es. la somma A1;A5 non considera le celle A2 A3 e A4 ma solamente la cella A1 e la cella A5.

Per formattare il foglio elettronico occorre tenere presente:
- FONT di default (Tipo di carattere e dimensioni) = Arial 10 pt.
- ZOOM = 100%
- File/Imposta pagina
- scheda Pagina (Orientamento/Proporzioni/Formato)
- scheda Margini (superiore e inferiore cm 2,5 - dx e sx 2 cm - intestazione e piè di pagina 1,3 cm –

centra nella pagina: orizzontalmente e/o verticalmente)
- scheda Intestazione/piè di pagina
- scheda Foglio (per attivare l'opzione Stampa/Griglia e per attivare l’opzione Stampa Intestazione di righe e di colonne, cioè le lettere delle colonne A, B, C, ecc. e i numeri delle righe 1, 2, 3, ecc.)
- Formato/Celle (scheda: Numero – Allineamento – Carattere – Bordi – Motivo – Protezione)
- Formato/Riga/Altezza (default 12,75)
- Formato/Colonna/Larghezza (default 8,43)
- Inserisci celle, righe, colonne, Immagin ( da ClipArt, da File, da scanner o fotocamera digitale, Organigramma, Forme, WordArt).

Per stampare le formule: Strumenti/Opzioni/Visualizza/Formule
Per ordinare i dati: selezionare l’intervallo dei dati da ordinare e cliccare sul pulsante ordine crescente (A-Z) o decrescente (Z-A) dalla barra degli strumenti standard (oppure Dati/Ordina)
Per copiare un file di Excel in Word: Copia/Incolla speciale
Per copiare dei valori da un foglio ad un altro all’interno dello stesso file o cartella: ES. Se nel Foglio1 la cella E18 contiene il risultato 9.000, per trasferire tale risultato nella cella B13 del Foglio3, occorre:
- posizionarsi nel Foglio 3
- posizionarsi nella cella B13 e digitare =’Foglio1’!E18

Esempi di funzioni:
=SOMMA(A1:A5) per effettuare la somma (si può cliccare anche il pulsante col simbolo della sigma greca
maiuscola che si trova nella barra degli strumenti standard)
=MEDIA(A1:A5) per effettuare la media
=MIN(A1:A5) per estrarre il numero più piccolo di un determinato intervallo

=MAX(A1:A5) per estrarre il numero più grande di un determinato intervallo
=OGGI() per la data corrente

Esempi di espressioni matematiche

I riferimenti possono essere:
1. relativi (A1) = l’indirizzo è libero sia nella colonna sia nella riga
2. assoluti ($A$1) = l’indirizzo rimane inalterato sia nella colonna sia nella riga
3. misto:
•$A1 = si blocca la colonna
•A$1 = si blocca la riga

N.B. = per anteporre il simbolo $ si può premere il tasto funzione F4 dopo aver scritto il riferimento relativo oppure si può digitare il simbolo $ che si trova nel tasto n. 4 della tastiera alfa-numerica, in posizione di Shift

1) Esempio con riferimento relativo
Nella cella A5 è contenuta la formula =SOMMA(A1:A4); la copio in B5, essa diventa
=SOMMA(B1:B4)

2) Esempio con riferimento assoluto
Nella cella B1 è contenuta la formula =SOMMA($A$1:$A$4); se la copio in E3, essa diventa
=SOMMA($A$1:$A$4)

3a) Esempio con riferimento misto
Nella cella C1 è contenuta la formula =$A1*B3; se la copio in D2, essa diventa
=$A2*C4

3b) Esempio con riferimento misto
Nella cella C1 è contenuta la formula =A$1*B3; se la copio in E3, essa diventa
=C$1*D5

Altri esempi con i riferimenti

1° esempio – nella cella A1 ho la formula con riferimenti assoluti =$B$2+$C$3; la copio in E5, diventa
=$B$2+$C$3 (resta la stessa formula)

2° esempio – nella cella A1 ho la formula con riferimenti relativi =B2+C3; la copio in E5, diventa
=F6+G7

3° esempio – nella cella A1 ho la formula con riferimenti misti =$B2+C$3; la copio in E5, diventa

=$B6+G$3

DIAGRAMMI o grafici (anche tridimensionali o 3D)
1. istogramma (non in pila) = confronta i valori di più categorie (rettangoli in verticale)
2. a barre (non in pila) = confronta i valori di più categorie (rettangoli in orizzontale)
3. linee = rileva la tendenza dei dati al variare di alcune condizioni
4. a torta (o aerogramma) = consente di rappresentare i dati in forma percentuale
5. dispersione XY = confronta coppie di valori
6. anello = simile a un grafico a torta ma può contenere serie multiple
7. azionario = per quotazioni azionarie massime, minime e di chiusura; sono necessarie 3 serie di valori nell’ordine indicato
8. cilindri, coni, piramidi

I grafici possono essere creati:
- sul foglio di lavoro
- su un foglio a parte

Creazione di un grafico:
•selezionare l’intervallo
•cliccare su “Creazione guidata grafico” sulla barra degli strumenti standard
•appare la finestra di dialogo “Autocomposizione grafico - Passaggio 1 di 4” clic su Avanti
•passaggio 2 di 4 = scelta del grafico
•passaggio 3 di 4 = prevede i dati nelle righe e prevede le categorie (o etichette di testo) nelle colonne
•passaggio 4 di 4 = si può aggiungere titolo-grafico, nome asse X e asse Y, legenda, ecc.
•Fine

Modifica i dati di un grafico:
•doppio clic sul grafico per attivarlo
•appare circondato da un bordo con quadratini (o maniglie)
•apportare le modifiche desiderate

Cambiare tipo di grafico:
•doppio clic sul grafico per attivarlo

•cambiare grafico e apportare le correzioni dovute
Per visualizzare la BARRA DEGLI STRUMENTI GRAFICO = Visualizza/Barra degli Strumenti/Grafico

Il Data Base in Excel
Il menu nel quale sono contenuti i comandi per la gestione di un database di Excel è Dati
Nel Database di Excel i dati vengono organizzati in Tabelle.
All’interno di esse, sono visualizzati:
•i campi = sono le colonne e descrivono le caratteristiche di ogni singolo record
•i record = sono le righe e descrivono le proprietà di ogni oggetto
Per inserire i dati nei campi si possono utilizzare i Moduli, cioè delle finestre particolari che sveltiscono l’input dei dati.
I dati inseriti possono essere ricercati e messi tra di loro in relazione con l’utilizzo dello strumento Filtro automatico.


Funzioni

1) FUNZIONE ARROTONDA = serve per arrotondare matematicamente un numero
La sintassi è =ARROTONDA(num;num_cifre)
Quattro Esempi sull'arrotondamento del numero 291,60554 (scritto nella cella A1)

a) arrotondamento al numero intero più vicino
=ARROTONDA(A1;0) RISULTATO 292

b) arrotondamento al numero di decimali specificato
=ARROTONDA(A1;1) RISULTATO 291,6

c) arrotondamento alla decina più vicina
=ARROTONDA(A1;-1) RISULTATO 290

d) arrotondamento al centinaio più vicino
=ARROTONDA(A1;-2) RISULTATO 300
N.B. = da 0 a 4 si arrotonda per difetto - da 5 a 9 si arrotonda per eccesso

2) FUNZIONE SE = serve per inserire in una cella una formula al verificarsi di certe condizioni
La sintassi è =SE(condizione;1^ possibilità;alternativa)
[se – allora – altrimenti in inglese if – then – else]
Gli Operatori di Confronto che occorre utilizzare nelle formule e nelle funzioni di Excel sono i seguenti:
uguale a =
maggiore di >
minore di <
maggiore o uguale a >=
minore o uguale a <=
diverso da <>

N.B. = nella funzione SE occorre utilizzare le virgolette
•per qualsiasi stringa di testo (ad es. “Milano” oppure “NON CALCOLA” oppure “NO”)
•per rendere la cella vuota, senza scrivere nulla al suo interno (ad es. “”)

1° Esempio = Un agente percepisce il 6% di provvigione per un fatturato inferiore a € 20.000; percepisce la provvigione dell'8% per un fatturato superiore a € 20.000.
La sintassi è la seg. =SE(A1>20.000;8%;6%)

2° Esempio = Se il contenuto della cella B6 è maggiore o uguale a 1500, allora calcola il 5% del valore della cella B6; altrimenti restituisci il valore 0).
=SE(B6>=1500;B6*5%;0)

3° Esempio = Se il contenuto della cella B6 è maggiore o uguale a 1500, allora calcola il 5% del valore della cella B6; altrimenti restituisci la cella vuota, senza nessun valore).
=SE(B6>=1500;B6*5%;””)

4° Esempio = Se Il valore contenuto nella cella A5 è uguale al valore 50.000, allora dividi per 2 il contenuto della cella A5; altrimenti se il valore è superiore o inferiore a 50.000, visualizza la stringa di caratteri NON
CALCOLA (racchiusa tra virgolette perché è testo)
=SE(A5=50000;A5/2;”NON CALCOLA”)

Registrati via email