Huey
Huey - Genius - 3870 Punti
Rispondi Cita Salva
SPERO SIA UTILE A CHI L'AVEVA CHIESTO

Obbiettivo:costruire un convertitore da BASE N. A BASE 10 con excel
Dati da utilizzare:
Numero da convertire
base di partenza
lunghezza del numero da convertire
numero cifre max
numero massimo convertibile

Numero da convertire: un numero preso a piacere con qui si effettuerà la conversione
Base di partenza: base del numero da convertire
Lunghezza del numero da convertire:numero di cifre presenti nel numero da convertire
Numero di cifre max: numero massimo di cifre del numero da convertire
Numero massimo da convertire: numero massimo che il convertitore può convertire.
PROCEDIMENTO
1-Abbiamo inserito nel primo foglio di excel i dati utili con a fianco i dati numerici che servono per svolgere la conversione
2-abbiamo inserito le posizioni dall’uno al sedici in orizzontale sul foglio
3- abbiamo inserito usando la funzione stringa estrai, un numero da convertire sotto le caselle delle posizioni in questo ordine:l’ultima cifra del numero da convertire sotto la posizione uno, la penultima sotto la posizione due e così via.
4-sotto ogni cifra del numero da convertire abbiamo inserito usando,la funzione valore,il valore della cifra analizzata.
5-usando la funzione se abbiamo creato un “controlla errori” che verifica eventuali errori nella conversione.
FORMULE
Numero massimo convertibile: =b5^b7-1(es. caselle)
Singole cifre: =SE($B$6<C11;0;STRINGA.ESTRAI($C$4;$B$6-C11+1;1)) (es. caselle)
Valore cifre: =VALORE(d12) (es. caselle)
Controlla errore: =SE(E(E13>=0;E13<$B$5);"";"e" ) (es. caselle)








Obiettivo:costruire un Convertitore da BASE 10 A BASE N
Dati da utilizzare:
Base:base nella quale bisogna rappresentare il numero
Numero massimo rappresentabile:numero massimo che il convertitore può rappresentare
Numero da rappresentare:numero da trasformare in base N dalla base 10
PROCEDIMENTO
1-prima di tutto abbiamo trovato il numero massimo rappresentabile .
2-in un’altra cella abbiamo inserito il numero da rappresentare(es. A11)
3-nella cella (d2) abbiamo inserito la base nella quale deve essere trasformato il numero.
4-in (f3) abbiamo usato la funzione INT per trovare il risultato intero della divisione tra il numero da rappresentare e la base.Nel nostro caso =INT(a11/$d$2)
5-in (f4) abbiamo usato sempre la funzione INT,però dividendo il risultato intero della prima divisione per la base.Dopo di questo abbiamo trascinato la formula verso il basso.
6-in (g3) abbiamo usato la funzione RESTO per trovare il resto della divisione tra il numero da rappresentare e la base.Nel nostro caso =RESTO(A11;$d$2)
7-In (g4) abbiamo usato la funzione RESTO per trovare il resto della divisione successiva.Nel nostro caso =RESTO($f3;$d$2)
8-Per la base 16 abbiamo fatto una tabella di conversione numeri-lettere dove la lettera A=10;B=11;C=12;D=13;E=14;F=15
FORMULE
Numero massimo rappresentabile (base 2): =(2^20)-1
Numero massimo rappresentabile (base 8 ): =(8^20)-1
Numero massimo rappresentabile (base 16): =(16^20)-1
Risultato della divisione tra il numero da rappresentare e la base: ==INT(a11/$d$2) (es. celle)
Resto della divisione tra il numero da rappresentare e la base: = RESTO(A11;$d$2) (es. celle)
Resto della divisione successiva: =RESTO($f3;$d$2) (es. celle)
Come guadagno Punti nel Forum? Leggi la guida completa
In evidenza
Classifica Mensile
Vincitori di novembre
Vincitori di novembre

Come partecipare? | Classifica Community

Community Live

Partecipa alla Community e scala la classifica

Vai al Forum | Invia appunti | Vai alla classifica

andrea1085

andrea1085 Blogger 387 Punti

VIP
Registrati via email